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Introduction
In this introductory course, you will become familiar with and comfortable in the Maple environment. You 
will learn how to use context menus, task assistants, and palettes to perform powerful analyses and create 
high-impact graphics with only a minimal knowledge of commands. You will also learn how to create 
technical reports that capture the knowledge behind an analysis directly in the Maple document. This course 
will give you the tools you need to get started quickly, and a solid foundation upon which to build your 
future Maple explorations.

To try this material on your own, start with an empty Maple document.  Perform the steps found in the left 
column of each table below.  The results of each step are displayed in the right column for your reference. 

Note for non-Windows or international users: The keystrokes given in this document are for Windows 
using a QWERT keyboard.  If you are using a different platform or keyboard, see Help> Quick Help for the 
list of the most common keystrokes. 

Talking to Maple
In this section, you will learn the basics of asking Maple a question and getting a result.

Steps Results

Using [ENTER]

When you launch Maple you start with a blank 
document, with menus and toolbars at the top, 
palettes on the side. At the cursor, you can start 
typing math. Press [ENTER] to see the result. 

Example: Type "1+2 [ENTER]".
Notice that the result appears on the next line.

1C2
3 (2.1)

Using [Ctrl][=]

In the example above, we obtained a result by 
pressing [ENTER] after our input. 

You can also get Maple to return the result on the 
same line as your question by typing [Ctrl][=] (hold 
down the control key, then press the = key). 

Example: Type "x+5-2" then [Ctrl][=].

x  C 5  K 2 = xC3
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Context Menus

You can use Maple's context menus to perform a 
wide variety of mathematical and other operations.  

Example: Place your cursor on the last result, and 
right-click. The context menu offers several 
operations to choose from according to the 
expression that you are using.  To integrate this 
expression, select Integrate, then x.

Example: To plot the result of the integration, right-
click on the result, and then select Plots > 2-D Plot.

The context menus are self-documenting. The text 
above the arrow shows what operation has been 
performed.

x  C 5  K 2 = xC3
integrate w.r.t. x 1
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Changing the Problem

Mathematics in a Maple document are live. You can
go back, make changes, and re-execute the problem 
to obtain a new result.

Example:  Go back to your original calculation of "
1  C 2", change the number "1" to a "3" and press
[ENTER]. Note the change in output.

Example:  In the context menu example, above, 
change the "x"  to ""10  x"  ".  Highlight the entire 
line, including the plot, then click the execute 
button, , found at the top of the Maple 

worksheet. All selected calculations are updated.

3C2
5 (2.2)
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Tip: Clicking on the "execute all" button, ,  recalculates the entire document. 
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Entering Math
There are a number of methods to enter math into Maple.  You can enter math using a combination of 
palettes, keyboard shortcuts, context menus and commands.  Most operations can be entered in more than 
one way, so you can pick the method you are most comfortable with.

Steps Result

Exact Answers and Numeric Approximations

Maple calculates exact answers (i.e. fractions 
remain as fractions). 

Example: On a new line, enter 1/2 + 1/3. 
Note that the / automatically moves you to the 
denominator. The right-arrow will take you out.  
Press [Ctrl][=] to see the result on the same line.

Maple also calculates numeric approximations.  
Example: Right-click the above result and select
Approximate from the context menu. Select 
accuracy of 5 digits.

If your problem uses decimal approximations 
already, Maple will return the answer in the same 
format.  
Example: Try the example on the right. 

You can apply different formatting to numeric 
results.
Example: Right-click the above result and select
Numeric Formatting... from the context menu. 
Select Scientific, then press Apply Formatting.

1
2

C
1
3

 = 
5
6

1
2

C
1
3

 = 
5
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at 5 digits
0.83333

0.5  xC
1
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x = 0.8333333333  x

0.5 xC
1
3

x = 8.33#10-1  x
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Palettes

Maple has over 1000 palette symbols within the 20 
palette menus.  You can also use Maple's
expression palette to input data.  The expression 
palette contains fill-in-the-blank templates for 
common operations.

Example: Use the Expression Palette, find the 
integral of 4$ t6 Csin t dt. Open the expression 
palette (click on Expression on the left-hand side of
your Maple document) and click the indefinite 
integral button.  An indefinite integral template will 
appear in your worksheet.  Fill in the place-holders 
(use [TAB] to move to the next placeholder). When 
done, press [ENTER] to evaluate.
Note: Use ̂  to create a superscript, and right-arrow 
to get out again.

Example: Use the expression palette to find the limit
of a function.

Tip: Put frequently used palette entries on the 
Favorites Palette. Right-click on the palette button 
and select Add to Favorites Palette

4$ t6 Csin t dt

4
7

 t7Kcos t (3.1)

lim
x/0

sin x2

x
 = 0

Symbol Recognition

You can use the Handwriting palette to find the 
symbol you want. 

Example: Enter 
100
3

, then use the context menu to 

approximate the result to 5 digits.  Open the symbol 
recognition palette, sketch the "approximation" 
symbol, and press the Recognize button.  Drag the 
new symbol to your worksheet to replace the arrow. 

100
3

at 5 digits
33.333

100
3

z33.333 

Symbol Completion

The symbol completion mechanism provides an 
alternative to palettes for entering symbols.

Type the first few characters of the symbol name, 
and press [Ctrl][Space]. Choose the symbol you 
want from the list. 

Example: Try entering  π
2
C x

To enter π, type pi [Ctrl][Space].  

For x , enter sqrt [Ctrl][Space].

π

2
C x

π

2
C x (3.2)



Maple Quick Start 6

Case-Sensitivity

Maple is case-sensitive.
 
Example: Enter " x  C x ".
Example: Enter " y  C Y  ".
Compare the results.

xCx = 2  x
yCY = yCY

Implicit Multiplication

Maple understands implicit multiplication. 

Example: Type " 3  x "  for "3 times x".

To multiply two variables, use a space. 
" x  y " means "x times y", but " xy " means the 
variable whose name is "xy".
Example: Type "x [ space] y  C xy ".
If you choose to Differentiate using the context 
menu, you will see that x, y, and xy are treated as 
three separate variables due to the way they were 
entered.

You should be careful using implicit multiplication 
in Maple to avoid confusion with function calls.  To 
us,  f xC1  looks like a function call, and 
x xC1  looks like implied multiplication.  Maple 
understands both of these as function calls.

Example:  Enter 
x xC2

x
 using no space, a 

space, and an explicit multiplication sign. Ask 
Maple to calculate each result so you can see the 
differences.

When multiplying with brackets you can use a space
to achieve implicit multiplication, but it is usually 
safest to explicitly use the multiplication symbol.

3  xC5  x = 8  x

x  y  C xy = x  yCxy

f xC1  = f xC1

x xC2
x

 = 
x xC2

x

x  xC2
x

 = xC2

x $ xC2
x

 = xC2

Mathematical Notation

Maple understands familiar mathematical notation. 

For example, Maple understands that y''Cy'Cy = 0 
is a differential equation in y x . 

Example: Enter the equation listed above (using the 
single quote key for the prime notation).  To verify 
that it is in fact a differential equation, select Solve 
DE from the context menu. 

y''Cy'Cy = 0/

y x = _C1  e
K

1
2

 x
 sin

1
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 3  x

C_C2  e
K
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 cos

1
2

 3  x
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Label References

Maple uses label references.

Whenever you use [ENTER] to get a response, the 
result is automatically given a label reference.  To 
refer to a previous result in a computation, use [Ctrl]
[L] and enter the label reference number.

Example: Multiply the result π
2
C x  (from above) 

by x, using labels.

To reference an equation from another document, 
use  Insert > Reference...

(3.2)$ x

π

2
C x  x (3.3)

Maple Commands

You can always enter Maple commands by typing 
them directly. Examples of Maple commands will 
be found throughout this course.

Example: A common command is the assignment 
statement, := (colon equals).  

Note:  Anything you want Maple to evaluate (e.g.. 
assignment statements), must be entered in Math 
mode.  Anything entered in Text mode will be non-
executable.

costA d 5 x
5  x (3.4)

costB d 4 x
4  x (3.5)

costACcostB
9  x (3.6)

Tip: Find the list of keyboard shortcuts for your platform.  Click Help > Quick Help menu, and select Math
Editor Shortcuts.

Combining Text and Math
In Maple you can combine math and text in the same paragraph to help formulate mathematical sentences. 

Steps Result

Example: Start by entering a simple computation.

Go back to the start of your computation (place the 
cursor to the left of your expression), press [F5]to 
change from math input to text input, and start 
typing text.

x3
Cx2

C3   dx  = 
1
4

 x4
C

1
3

 x3
C3  x

The integralx3
Cx2

C3   dx = 

1
4

 x4
C

1
3

 x3
C3  x

You can also input text in place of the equals sign 
(=).  Click on the equals sign and replace it with 
some additional text.

The integral x3
Cx2

C3   dx is equal to  

1
4

 x4
C

1
3

 x3
C3  x
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Place your cursor at the end of the output, press 
[F5], and complete the rest of the sentence.

The integral x3
Cx2

CxC3   dx is equal to 

1
4

 x4
C

1
3

 x3
C

1
2

 x2
C3  x, as you can plainly 

see.

Modify some of the terms in the problem, highlight 
the entire sentence and press the  button to re-

execute the computation. 

The integral x3
C5x2

CxC3   dx is equal to 

1
4

 x4
C

5
3

 x3
C

1
2

 x2
C3  x, as you can plainly 

see.

Tip: Pressing [F5]allows you to easily toggle between math input and text input.
Tip: In math mode, the cursor is slanted and has a dotted box around it. In text mode, the cursor appears as a 
vertical bar. 
Tip:  To check what mode you are in, look at the top left of the toolbar. 
In text mode it will look like . 

In math mode it will look like . 

You can also use these buttons to change modes as an alternative to pressing F5. 
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Plotting
Maple can produce 2-D and 3-D plots of equations and expressions. 

Steps Result

2-D Plots

Now we will demonstrate plotting in Maple.  The 
fastest way to plot an expression in Maple is to use 
the context menu. 

Example: Enter an expression in x (e.g.. sin2 x , 
right-click on the expression, and select Plots > 2-D 
Plot.

Example: Use the point probe to find the 
coordinates of different points in the graph. Click on
the plot, then move the cursor to different locations. 
The coordinates are displayed in the top left of the 
plot toolbar. 

Example: To pan the plot, right-click on the plot, 
and select Manipulator>Pan. Hold down the left 
mouse button and use the mouse to move the plot 
around. To scale the plot, perform the same steps, 
but select Manipulator>Scale.

Tip: You can also change the manipulator tool by 
clicking on the plot, and then selecting the 
appropriate tool from plot toolbar at the top of the 
Maple window:

sin2 x /

x
K10 K5 0 5 10

0.2

0.4

0.6

0.8

1
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Combining Plots

You can easily add another plot on the same set of 
axes.  

Example: Enter another equation in x (e.g.. 

sin
x
2

), highlight the new expression with your 

mouse, hold down the[Ctrl]key and drag it onto the 
plot.

sin2 x /

K10 K5 0 5 10

K1

K0.5

0.5

1

sin
x
2

Annotating Plots

You can add additional information to plots by 
using the drawing tools.  Lines, arrows, text, 2D 
math, and shapes are available.

Example: Click on the plot, then click on the 
 button on the toolbar. Use the text 

tool (T) to enter labels for the curves.  Use [F5] to 
toggle between text and math, and standard Maple 
math editor entry keystrokes. 

x
K10 K5 0 5 10

K1

K0.5

0.5

1sin2 x

sin
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Task Assistants and Tutors
As explored above, context menus are one way to solve problems without using Maple commands.  Task 
assistants provide another method.  Tutors are useful for teaching and exploring mathematical concepts.
The full list of assistants and tutors can be found on the Tools menu.

Steps Result

Using the Plot Builder Assistant

Plots can easily be created in Maple using the built-
in Plot Builder. 

Example: Enter the expression you want to plot.  
From the context menu, select Plots > Plot Builder.
 Using the Plot Builder, you can choose the kind of 
plot you want, add titles, and set options, all at once.
This example shows a 3D plot with the use of plot 
title, normal axes and style of surface with 
contours.

x2
Cy2

/

-5 -5x y

0 00

5 5

20

40

My Plot

The Plot Builder allows you to create more than just
ordinary 2-D and 3-D plots.  The example on the 
right is a ploar plot.

Example: Enter the expression 2 sin 4$tC1 .  
Select Plots > Plot Builder from the context menu.
 Select 2-D Polar Plot from the Select Plot Type 
list box, then click Plot.

2$sin 4$tC1 /

0 0.5 1 1.5
0

π

4

π

2
3 π
4

π

5 π
4

3 π
2

7 π
4
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You can also create an animation using the Plot 
Builder assistant. 

Example:  Enter the expression on the right, right-
click to invoke the context menu.
Select Plots > Plot Builder > select Animation 
from the Select Plot Type drop-down list, and click 
the Plot button.

Now click on the plot image - some new, plot-
specific, buttons will appear at the top left of your 
worksheet.  Click  and watch the animation. 

sin a  $ x2  C y2

π

2 /

a = 0.

Using the ODE Analyzer Assistant

Another useful Maple assistant is the ODE 
Analyzer.  

Example: Enter the differential equation on the 
right.  Select Solve DE Interactively from the 
context menu of this differential equation.

Under Conditions, click Edit to add initial 
conditions, such as y(0)=0 and y'(0)=1

• 

Select Solve Numerically• 
Press Plot• 

1
3

y'' C y'Cy = sin x
solve DE interactively

x
2 4 6 8 10

y
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Using the Exploration Assistant

The Exploration Assistant allows you to instantly 
create interactive mini-applications used to explore 
the parameters of the expressions

Example: Enter the expression you want to explore. 
Select Explore from the context menu.  In the 
submenu, input the parameters you would like to 
test.  If you do not want to explore a variable, check 
the box next to skip.  A new document will open 
with the function and sliders.  Move the sliders to 
see the results for the given values.

x$sin x a
$cos x b dx

Using Tutors in Maple

Maple provides several tutors which are useful for 
teaching and exploring mathematical concepts in the
subjects of:

Calculus - Multi-Variable• 
Calculus - Single-Variable• 
Differential Equations• 
Linear Algebra• 
Precalculus• 
Vector Calculus• 

Example: From the menu, select Tools > Tutors > 
Calculus - Single Variable > Integration 
Methods.  Enter a function and follow the example 
through by applying the correct rule at each step and
using the "Get Hint" button for help. 
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Entering Commands
While many operations in Maple can be done through the use of context menus and other interactive tools, 
Maple also has a rich command language.

Steps Result

Entering Maple Commands

Many commands are grouped together in packages. 
You can type the long name, or enter a with() 
command prior to using a command from that 
particular package.

Example: Create a Matrix, M, and apply the 
command LinearAlgebra Determinant M  to find
the determinant of M.

Note: If you do not provide the package name, 
Maple does not know the definition of this function,
and so simply returns the unevaluated expression.

You can avoid having to type the long-form of each 
command by pre-loading the desired package.  You 
can use a colon at the end of the command to 
suppress output. 

Example: Load the LinearAlgebra package first 
using a colon. Try again without the colon to see the
difference.
Example: Now calculate the Determinant of M 
using the short-form of the command. 

Command completion is very useful when typing 
out long command names. 
Example: Type Gau, then press[Ctrl][Space] to see a
list of possible completions.  Use the arrow key to 
select the desired command and press [Enter], or 
select the command with the mouse.

Tip: Many packages can be loaded through Tools > 
Load Package.  See Tools > Load Package > List 
All Packages... to see the complete list.

Md
2 3

3 4

2 3

3 4
(7.1)

LinearAlgebra Determinant M
K1 (7.2)

Determinant M

Determinant
2 3

3 4
(7.3)

with LinearAlgebra :
Determinant M

K1 (7.4)

GaussianElimination M

2 3

0 K
1
2

(7.5)
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Document Editing and Formatting Tools
Maple contains numerous word processing tools to help you create professional-looking reports.  For your 
reference, here is a list of some of the more common ones.

Feature Where to Find It

Built-in title and headings styles Drop-down list on toolbar

Sections and subsections Insert > Section, Insert > Subsection

Tables Insert > Table

Ability to edit table properties Right-click anywhere in the table, then select
Table>

Drawing canvas Insert > Canvas

Font control and ability to define new styles Toolbar buttons, Format > Styles...

Ability to insert images, spreadsheets and other 
objects

Insert > Image, Insert > Object

A spell-checker aware of mathematical terms Tools > Spellcheck

Hyperlinks and bookmarks Format > Convert to > Hyperlink
Format > Bookmarks...

Ability to add headers and footers View>Header Footer

Export to HTML File > Export

Configuring the Maple Environment
You can customize the Maple environment in many ways.  Below is a list of the most common ones.
Note that any option set through the Options menu can be set just for this session, or globally (every time 
you start Maple).

Feature How to Control Feature

Start-up dialog. Turn it off by clearing the check box on the dialog.
Turn it on always by Tools > Options, Interface 
tab.
See it anytime by Help > Startup Dialog...

Quick Help displayed on new documents. Turn it off by clearing the check box on the quick 
help.
Turn it on again by Tools > Options, Interface tab.
See it anytime by pressing [F1].

Option for new documents to start in Document 
mode (no prompt, context menu commands hidden) 
or Worksheet mode (prompts, all commands shown)
.

Tools > Options, Interface tab.
Default format for new worksheets...
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Option to enter math in 2-D (default) or 1-D? (Note:
Choice only available in worksheet mode.  All math
must be entered in 2-D in document mode.)

You can also control the input type for individual 
lines, without changing the overall default.

Tools > Options, Display tab
Input Display...

x2
OOOO 
vs.

x^2;OOOO 

Use context menu on the line above.  Selecting
Convert to > 2-D Math Input turns the above line
into:

x2;OOOO 

Number of digits displayed in calculation results.
Maple displays 10 digits by default (though it 
calculates with more). 

Tools > Options, Precision tab
Round screen display to..

For example, show the floating point value of π. The
default result is:

evalf π ;OOOO 
3.141592654 (9.1)

After setting the screen display to 5, the result is:

evalf π ;OOOO 
3.14159 (9.2)

Add item to Favorites Palette.

Palettes can be reordered, and individual palettes 
can be moved from one dock to the other, or turned 
off completely.

Palette docks can also be expanded and collapsed.

Right-click on palette button, Add to Favorites 
Palette

View > Palettes > Arrange Palettes...

Use the View > Palettes menu, or the small arrows 
at the top of the palette to expand and collapse.  For 
the left-hand-side dock, these arrows are in the top-
right corner of the palette, to the right of the scroll 
bar.
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Getting Help
Maple has an extensive help system, including help pages, online manuals, an integrated dictionary of 
mathematical and engineering terms, examples, and tutorials.

Steps Useful for

Select the Help > Maple Help menu to display the 
help browser.  Enter the topic name (e.g.. "fourier") 
into the search box.

Search and browse full help system, including help 
pages, dictionary and manuals.

To get help on a particular topic, use the ? notation. 
E.g. ?int

If topic name already appears in your document, 
place the cursor on the word and press [F2].

Instant access to the help page when you know the 
topic name or command name.

Press [F1] for Quick help. Follow links for full 
explanations.

Instant help on common tasks.

Help > Quick Reference Card (or [Ctrl][F2]) Succinct overview of important topics.

?examples,index Example documents illustrating different 
mathematical and programming commands.

Tools > Task > Browse for task templates. Fill-in-the-blank templates. Organized by concept, 
not command name.

Printed manuals are included with the product. The
Getting Started Guide and User Manual are also 
available through the help system. Select Help > 
Manuals, Dictionary, and more>Manuals to view 
the manuals.

Conceptual overviews, more in-depth explanations.

Help > Take a Tour of Maple for introductions to 
topics and example applications.

Quick introduction to a variety of Maple topics in 
slide-show format.
Examples of polished interactive technical 
documents.


